Yamaha YXZ Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
723 Posts
Discussion Starter · #1 · (Edited)
I have 11500 miles on my 2016 SE. It has Graves exhaust and ECU tune. I had something interesting happen a couple times in one ride. I was sitting at idle while at a cattle control gate opening/closing with everything seemingly normal . My machine died while just sitting there idling and gave me a code 30 in the display. First time, I turned off the key and restart without issue. The second time it happened, I did not cycle the key off and just tried to restart it..... engine cranked but no start, then I turned the key off and tried to start and machine fired right up. Got home and looked it up in my manual and this is a "latch up" failure. The description itself explains why I had to turn the key off to get a successful re-start. The potential causes are lean angle sensor (which I believe is no longer relevant based on ECU tune - given I can roll it and no engine cut-off without me turning off the key), oil pressure switch indicating low pressure or an ECU. Oil level is just fine and was at the time of occurence. Just went for a spirited ride yesterday with plenty of idling time at gates etc. and not a single issue. Planning to replace the oil pressure switch at next oil change.... just because. Anyone else ever have a similar experience?
 

·
Registered
Joined
·
723 Posts
Discussion Starter · #3 ·
Interesting. I do not have Rekluse clutch. Not sure what mechanism would cause the code 30 due to clutch configuration. The potential causes are low oil level/pressure or lean angle sensor or ECU, according to my manual. I was idling in neutral both times it happened and not holding the clutch in.
 
1 - 3 of 3 Posts
Top