Yamaha YXZ Forums banner
1 - 11 of 11 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
Hi I have a 2016 yxz 1000 se I love this machine and having an issue with the check engine light coming on only in gear while throttling….. and soon and I release or let off the throttle the check engine goes off. The check engine light does not illuminate when in neutral revving the motor . Any help would be very much appropriate
 

·
Super Moderator
2018 YXZ SE, CageWRX cage, 2019 Gears, Rekluse Clutch, Heavyweight Flywheel, RR Intercom & Radio
Joined
·
309 Posts
Is it displaying any codes?

Nate
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #3 ·
Hi I have a 2016 yxz 1000 se I love this machine and having an issue with the check engine light coming on only in gear while throttling….. and soon and I release or let off the throttle the check engine goes off. The check engine light does not illuminate when in neutral revving the motor . Any help would be very much appropriate
Hi I have a 2016 yxz 1000 se I love this machine and having an issue with the check engine light coming on only in gear while throttling….. and soon and I release or let off the throttle the check engine goes off. The check engine light does not illuminate when in neutral revving the motor . Any help would be very much appropriate
 

·
Registered
Joined
·
759 Posts
Does it run bad when it’s on?
 

·
Super Moderator
2018 YXZ SE, CageWRX cage, 2019 Gears, Rekluse Clutch, Heavyweight Flywheel, RR Intercom & Radio
Joined
·
309 Posts
If its running fine, not throwing codes, and your not having any other issues.

Are you the original owner? Is there any aftermarket electrical components?

I'd start simple. I'd start checking connectors for security and no corrosion. Wires for any signs of shorting. Any components that could generate a field or signal.

And probably top of that list would be checking and cleaning ALL ground cables and straps.

Just my .02

Nate
 
  • Like
Reactions: fortrdb

·
Registered
Joined
·
5 Posts
Discussion Starter · #8 ·
If its running fine, not throwing codes, and your not having any other issues.

Are you the original owner? Is there any aftermarket electrical components?

I'd start simple. I'd start checking connectors for security and no corrosion. Wires for any signs of shorting. Any components that could generate a field or signal.

And probably top of that list would be checking and cleaning ALL ground cables and straps.

Just my .02

Nate
Yes original owner and yes have a light bar radio and also have a fuel tuner . I don’t use it as much as I’d liked to only has 730 miles does still have original battery
 

·
Registered
Joined
·
759 Posts
Did you try taking the fuel controller out of the system?
 
  • Like
Reactions: WWARt

·
Super Moderator
2018 YXZ SE, CageWRX cage, 2019 Gears, Rekluse Clutch, Heavyweight Flywheel, RR Intercom & Radio
Joined
·
309 Posts
Do the easy and simple stuff first. Properly charged battery that will hold a charge. All battery and electrical connectors cleaned and tight.

Disconnect all aftermarket equipment. Especially the fuel tuner.

Add each one back in and test.

The two stand outs are the fuel tuner and the battery. The battery would be suspect after 5 years. The fuel tuner would be suspect because it could fault another system but still not throw a code.

Nate
 

·
Registered
Joined
·
6 Posts
If its running fine, not throwing codes, and your not having any other issues.

Are you the original owner? Is there any aftermarket electrical components?

I'd start simple. I'd start checking connectors for security and no corrosion. Wires for any signs of shorting. Any components that could generate a field or signal.

And probably top of that list would be checking and cleaning ALL ground cables and straps.

Just my .02

Nate
Nicely done Nate.
 
1 - 11 of 11 Posts
Top