Yamaha YXZ Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
1,759 Posts
Discussion Starter · #1 ·
Only have 52 miles on my yxz . I tried to grease the fittings and could only get two of then to take grease. Either these bushings are real tight , I need more time on it or I am gonna have to take it apart to make sure it is getting grease properly . How about you guys? Exracer2
 
  • Like
Reactions: Salinedude

·
Registered
Joined
·
44 Posts
I'm going to do a full service this weekend and this will definitely be part of it. I'll let you know what comes of it.
 

·
Registered
Joined
·
589 Posts
They are set with very tight tolerances and sealed very well. Take the weight off the bushing can help but I wouldn't over grease. Take one off and have a look. There's a metal washer with a rubber seal then there's another thick rubber seal set against it. Same with my Wolverine that lives in mud and water.. took one of the arms apart and everything was still well greased and clean after 1000 miles of mud/water with major washing after every trip.
 

·
Registered
Joined
·
44 Posts
They are set with very tight tolerances and sealed very well. Take the weight off the bushing can help but I wouldn't over grease. Take one off and have a look. There's a metal washer with a rubber seal then there's another thick rubber seal set against it. Same with my Wolverine that lives in mud and water.. took one of the arms apart and everything was still well greased and clean after 1000 miles of mud/water with major washing after every trip.
Thanks for the heads up. What I expected but still nice to hear it's built strong.
 
1 - 8 of 8 Posts
Top