Yamaha YXZ Forums banner
21 - 28 of 28 Posts

·
Registered
Joined
·
80 Posts
I used 100% stock clutches. All I did was put the old setup on the new Oil Modded Hub exactly like it was from the factory. Mine did come with a different cap washer. It seems that TW made a change at some point with the kits. Here is what mine came with. Auto part Gear Rotor Clutch part Clutch
Auto part Clutch Fashion accessory Gear
 

·
Registered
Joined
·
16 Posts
Just installed a IRP and I forgot to put one of the spacer washer thing that goes behind pressure plate and I started the machine and then shifted into first gear and it immediately shut itself off and threw Code Sh17 and it's stuck in gear and will not start. When I realized I forgot a part I fixed it and everything looks right but code is still up and it won't go into neutral or start
 

·
Registered
Joined
·
16 Posts
I used 100% stock clutches. All I did was put the old setup on the new Oil Modded Hub exactly like it was from the factory. Mine did come with a different cap washer. It seems that TW made a change at some point with the kits. Here is what mine came with. View attachment 108426 View attachment 108434
Blitz, what is your clutch pack setup? Did you stick with the stock number of steels and frictions? Did you keep the judder springs?

Sent from my SM-G950U using Tapatalk
just installed my IRP on a 2017 yamaha yxz1000rss and I'm having alot of trouble down shifting has anyone else had this trouble if so how did you fix it
 
21 - 28 of 28 Posts
Top