Yamaha YXZ Forums banner
1 - 16 of 16 Posts

·
Registered
Joined
·
21 Posts
Discussion Starter · #1 ·
So Install is completed, Car absolutely flies, Running on the Alba Stage 2 tune ECU, Trinity Stage 5 slip on Etc... Thing is At 3K-3500 RPM the Car Stumbles in every gear until it passes that RPM point. Any ideas?
 

·
Registered
Joined
·
5 Posts
I sent an email to Alba about my issues. I’ve had the turbo for about 10 hours now but it hasn’t improved. Does your car randomly idle down to about 900 rpm and die? Do you know what brand map sensor your turbo kit included? Mine is the gap innovations sensor.
 

·
Registered
2019 YXZ1000R SS SE White
Joined
·
190 Posts
Wonder if they have a tune for each kit, yet? The v.2 kit is going to be moving more air earlier (better spool), so perhaps if they tuned for the later v.2 GYTR kit they are loading up a bit more fuel down low where your v.1 kit is not at target boost yet.
 

·
Registered
Joined
·
5 Posts
Mine feels like it’s loading up a bit prior to coming on boost. 2500-4000 rpm with Very light throttle or cruising at slow speeds with steady throttle. Mine also wants to die coming to a stop especially before it’s completely warmed up. Once it’s up to 180° mine does get better. I talked to Nate this afternoon at Alba so I’ll keep you posted on what he says. I sent a couple of videos to him today.
 

·
Registered
2019 YXZ1000R SS SE White
Joined
·
190 Posts
Mine feels like it’s loading up a bit prior to coming on boost. 2500-4000 rpm with Very light throttle or cruising at slow speeds with steady throttle. Mine also wants to die coming to a stop especially before it’s completely warmed up. Once it’s up to 180° mine does get better. I talked to Nate this afternoon at Alba so I’ll keep you posted on what he says. I sent a couple of videos to him today.
Definitely do. Always good to know what is in store for us with this as a future project (have a v.1 GYTR Turbo kit I'm needing to install).
 

·
Registered
2019 YXZ1000R SS SE White
Joined
·
190 Posts
Exact same issue here. I installed the GYTR kit approximately 15 hours ago. Seems to be running very rich before getting into boost at about 4-4500 rpm's.
Do you have the v.1 GYTR kit or the brand new v.2 GYTR kit with the smaller turbo? Also are you on the OE tune or an Alba?
 
1 - 16 of 16 Posts
Top